Under the Ho‘o'd"_: A close l(‘)"okwat l")ix.elm.iil_’.s CSS
table-less templates
Ever wondered how to work

with a CSS template design?

Heather Waterman takes you through a general overview of
what you can expect to find in PixelMill’s CSS templates.



Under the Hood: A close look at PixelMill’s CSS table-less templates.

What do you mean by table-less?

You may think you know the difference between a tables-based design and a table-less design — one
uses tables and one does not — but there is much more going on under the hood than just the absence
of tables. A table-less template is one that relies on a stylesheet for the design and formatting instead of
using nested tables, sliced images, and spacer gifs to create a page layout. More importantly, our table-
less templates (also called CSS Templates) are coded to meet with today’s web standards which, more
than a site that /ooks nice, involves clean and compliant XHTML code.

Several reasons for losing our tables and moving to a table-less design:
e Meets web standard and accessibility guidelines (pixelmill.com/support/al0/kb101564.htm)

e Helps search engine optimization

e Stylesheets are more flexible and allow easier global design changes

e Pages load faster

e You have future opportunities for making alternative versions of your web site (for mobile
devices, etc.) without having to make a whole new site

Those are just a few reasons to move from a table based design to CSS. | have to say | used to be an
exclusively tables-only designer, but now having made the transition, | cannot imagine ever going back
to designing with tables.

Let’s take a look under the hood at one of our templates

Please note that while this is one example of a table-less CSS template, the way the code and CSS is built
will vary from developer to developer. This article will give you a good general idea of how CSS
templates are structured and how they work, however.

yourlogohere

+ This template is called Gradual Law and was added
to our catalog Feb-2007 by John Galt’s Templates.

- This template is complaint with the XHTML Strict
v specification and uses CSS.
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Under the Hood: A close look at PixelMill’s CSS table-less templates.

Note: According to PixelMill Standards XHTML Transitional is the lowest level of validation for
our templates.

(&l Web site ngttlngstarted.hh "{hllex.htm-' :
<] [<body>| [<div=container>| | <dv=body3col>| [<divebody1>| |<ul>| [<ii>]

$8 < !'DOCTYPE html PUBLIC "-//W3C//DID XHIML 1.0 Strict//EN" “http://www.w3.org/IR/xhtmll/DTD/xhtmll-atrict.dtd">

] </head>
b8 <body>
p88 <div id="container">
<!--webbot bot="Include™ U-Include="includes/top.htm"” TAG="BODY" --><div id="body3col™>
<div id="body2">
<!--webbot bot="Include” U-Include="includes/menu.htm" TAG="BODY" --><h2>

Heading 2</h2>
<p>Uze Heading 2 in the left column for a specialized header bar.</p>

Line 1: XHTML DOCTYPE

Line 5: The content type is specified

Line 7: Link style sheet is used.

Line 11: The entire layout is set with <div> tags in lieu tables. Each DIV tag gets a unique ID (ID’s

W NPR

can only be used once on a page and classes can be used many times on a page).

Here is just a quick diagram of how div tags in a CSS template work together with each other. This is a
general overview and does not reflect the template listed above.

<div id="container”> holds the layout width and position

<div id="toparea”> Logo and navigation may go here </div>

<div id="body”>

<div id="body2”> Left side column | <div id="body1”> Content will go here. :
|
content will go here </div> 1 !
|

</div> (this is the closing tag for the body)

<div id="footer”> Footer information goes here</div>

</div> (this is the closing tag for the container)

A quick note: If you are using FP2003, your WISYWIG view of the template will look distorted, the font
sizes will be very large your columns may have shifted, etc, this is okay! Your template is not broken. In
FP2003 you will need to use the File > Preview in browser to view your web changes.

3|Page
PixelMilll.com — Heather Waterman



Under the Hood: A close look at PixelMill’s CSS table-less templates.

To properly understand how to work within a CSS template you should have the style sheet open and
the web page you are working on in the split view mode in FrontPage, Expression Web, or
Dreamweaver. For this article we are using Expression Web.

SRR WTTTRE WA wz = w ooy
Folder List @ox il Web Site || gettingstarted.htm index.htm styles.css

() C:\Documents and SettingsHeather Watermar heml [ margin: Opx; padding: Opx; }

# ) _private

# () images 1 body

# | indudes
&% gettingstarted.htm
@ index.htm
|2 styles.css
#] template 1.him ] font . .
9] template2.htm ! want to modify the layout of this template.

Ad s =

You should have a good understanding of CSS if you

Style Sheet Page ;
Take amomentto || -
review the CSS so :
you are familiar o

with the IDs and i o

color: #5B6372; ’

You can make minor modifications without affecting
the layout of the template. For example, you can

acd change the font, font-size and link effects fairly
easily without needing to know advanced CSS.

Classes. )

() LT WIOCLITENIS 00 eI ST WaTETTaT
# O _peate
# 12 imoges
B 15 indudes
L8 petingstarted.him

<body>| | <dw scomtaner>| |<drv sbady3col>| |<divabody 1>/ | <p>|

<div ide"Body3cal™>

<hiéy
(& mdex.htm
L& styles.cas

o) i : Working in the spit screen mode will help you when
adding/deleting text so that the page’s DIV tags and other
layout tags are not accidentally deleted.

Each DIV tag has an ID or a Class. Note: IDs are set off with
“#” and classes are set off with “.” in the stylesheet.

¢ =z ] The top DIV tag on this pages is <div id="container”>. Once you
e =ik find this on your page, you can then refer to the STYLES.CSS
S [l page for the STYLE definition.

o — #container {... width: 950px; padding: 15px;

%Tf‘ 7 text-align: left; .....}

=S soidang :

E:“a::;l FE

f;.';’;fm:.n E

e B Split Screen Tab

N
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Under the Hood: A close look at PixelMill’s CSS table-less templates.

Replacing the template text

o YEU Sne

<body>| | <divacontainer >| | <div #body3col>| | <divabody1>| [<ul>]

YERnYSLaTLEU AT MIUEXIILI Ly

<!--webbot bot="

Heading 2<,-"12>

v idm"bodyl">
<ul>

"Include” U-Include

<p>Use Heading 2 in the left column for a specialized header bar.</p>
<p><img alt="Fhoto of gavel™ src="images/photol.jpg™ width="215" height="215" /></p></div>

<hl :l5B!I'!E!Ci!l")t&!:df!!(fﬂi)

--><h2>

<1i>

browser width.</1i>

3 web aitec/
site quickly and nn.‘w </1i>
mxmm—hnnd layout </strong>gives cleaner code. No
tables or JavaScript used!</li>

<li><strong>Fixed-width layout</strong> is for a minimum of 1024

ing> helpa you to start a web

<1i> Print sty

<11 A1l Ph

i menus,
andtme:maapl_wa columns mmammofmm:\ﬁnr cleansr printing.</1i>

out h

p filesc/ g> included.</1i>

<1i>

mmﬁ
<li>Tested to work in IE &, 7, Netscape &, Opera 7, 8, 9, FireFox
1, 2, and Safari 2.</11>

‘used for top, menu, and copyright area for easy editing.</li>

<11«

<ful>

TP T T L

1.0 and Section S0 accessible. </1i>

<hl>About CS55-based layout</hl>
<p>This template uses CSS-based layout - no tables are used

N

XHTML 1.0 Strict, CS5. Priority 2 WCAG

Joo,, Je0 100,

When you select the area
to be deleted or changed,
you will see that the area in
the split screen and/or
design area is selected.

| IR

Features

[ul]
* |Starter web site helps you to start a web site quickly and easily.
* |cSS-based layout gives cleanar code. No tables or JavaScript
used!
* |Fixed-width layout is for a minimum of 1024 browser width.
- Print strips out header, menus, and footer and displays
stacked on top of each other for cleaner printing.
. a!l Photoshop files included.
* linclude pages used for top, menu, and copyright area for easy
editing.
* |Tested to work in IE 6, 7, Netscape 8, Opera 7, 8, 9, % 1,2,

-% Able

AbleStock.com is th
hub fer professional
but the best in high-
free images. AbleStd
trademark of

Sballounad o %

Delete the template text and add your own. You SHOULD NOT copy text from Word or an existing site,
just select the text you want to add, copy the text into Note Pad then copy and paste the text into your
page. You can then apply the formatting (bold, italics, headings) using the tools in the editor so that the

proper HTML code is inserted.

Notepad

' Untitled -

olor s1t amer, consectetuer a
eleifend sed, pharetra egert,
In at magna. Cras metus.

Lorem 1psum
scelerisque,
urabitur lectus.

leo.
Ut

Nam Tempus b 1am porta so
non libero. curabitur congue.
/enenatis ut, tempor vitae, arcu.
cubilia Curae; sed sem odio, dictum

1iCitudin.

ItBE

1t !FCU eget orem.
et nisi sed turpis facilisis lobortis. Nullam
consectetuer erat. Vivamus pharetra facilisis
ac ante. Quisque mollis vehicula felis.

s1. Suspendisse SUSCIpiT magna at
lacus sed sem. Integer malesuada
commodo. Nulla pretium viverra augue.
Donec a enim.

NUMC condimentum,
Nam orci felis,
rhoncus eget,

urus vel pulvinar gravida,
lamcorper in, loboriis_a,
s. In hac habitasse platea

ul

1piscing

Cum SOC11s na[anP
Qu'l,qul’ magna auqur‘
curabitur in leo in odio p'lacaral
aliquam a,

Integer eget augue eu

pellentes.

vehicula risus.
In felis tellus,
Quisque a odio et metus convallis lacinia.

suscipit quis,

Alternatively, use Edit > Paste Special
when pasting in your content. This will
strip the copied content of formatting so
that the text will be formatted according

elit. Donec ter
Etiam digniss
mauris quam,

egestas in, so

portritor ve to the styles in the new template without
bringing in extra code and formatting that
bloats your code. Again, you can then
apply headings, bold, italics, and other
formatting using the editing tools so that

the correct HTML code is added.

e
suscipit met

placerat
feumat

nunc. M d ur

aretra pret
Proin enim purus,
malesuada s

e0 consequat leo
elit. M

dictumst. In molestie
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Under the Hood: A close look at PixelMill’s CSS table-less templates.

<Nl Clasy= JPEClal FrTatures</oLr

Lorem ipsum dolor ait amet, consectetuer adipiscing elic. Donec
tempor lacus dignissim ercs. Duis posuere lectus vitae ante. Nam
leo ligula, t scelerisque, eleifend sed, pharecra egec,
lec. Etiam dignissim condimentum lectus. Integer non dolor wvel
magna sollicitudin pellentesque. Mauris pharetra. Curabitur
lectus. In at magna. Cras metus. Uc mauris guam, placerat eget,
euismed in, aliguam a, diam. <br />

fhr

Navigation

= Home

=2 Getting Started
= Template 1

=» Template 2

Features

Jorem igsym delor sit amet,

seslenizaus, slaifend sed,
mmmumm Integer non dolor ygl magna sollicitudin
Manrs Rharstsa. Gueakitur legtys. In at magna. Cras metus:
quam, placeral sged auamed in, aliquam a, diam.

Nam tempus libgrs in diam pera sellisiudin. Cum sociis
et magnis dig parturient montes. nassetur
non libere. Curabitur congue. Q.msﬂ.us ]

in, tincidunt vel. fels. Ehasellus et felis. Dus libere matus,
XEnenans ub, temegr vitae, arcy. Qurabitug in leg in odip placerat
|ssslansaue. Veshbulum

ol

sensedislusr adwnisaing It Denss temear
latus dianissim sros- Buis pasusrs lectys vitae ante. Nam leg ligula,

Use Heading 2 in the left column for ey
a specialized header bar.

pharstra sazgt leo- E».@!I!QJM
ULM

DALPAYS B
odigulus mus. Sed pariior
magna augue, sgsstas in. sellickudin; trademark of
rhangus

ante psum pOmis 0 fausihus ars luetus =t ulidess £blestock.com

.'. AbleStock.com

AbleStock.com is the image download
hub for professionals, giving you nothing
= | but the best in high-resolution, royalty-
libers free images. AbleStock.com is a
Corporation,
a wholly-owned subsidiary of

mm pruratuon Wisit

Add your logo

10 <body class="two-column">
1 <div id="container">

l... £!—webbot bot="Include” U-Include="includes/top.htm"™ TAG="BODY"™ —-><div i

13 <div id="body2">

14 <!—webbot bot="Include" U-Include="includes/menu.htm" TAG="B0I

Heading 2</h2>

To add your logo, double click the

lding 1.special)</hl>

logo area at the top of the page.

<h4>HeRding 3</ha>
4 <h5>Heading S</hS>
<h&>Heading 6</hé&>

PO 2000 TR I =2 - X 20

L0, 9, 10
[]

for a specialized header bar.</p>

Include code in the HTML

¥ T L

Logo Area
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Under the Hood: A close look at PixelMill’s CSS table-less templates.

 Folder List 3] O X ||| web Site || gettingstarted.htm indechtm®  templatel.htm
I C:\Documents and Settings Watermar| | <hady. two-column > m=mw>
® ) _private
= B i PUBLIC "-//W3C//DID XHIML 1.0 Strict//EN" “http://www.w3.org/IR/xhtmll/DID/xhtmll-strict.ded
@ Q@ roces Includes Folder
& |2 indudes
& gettngstarted.htm <head>
gﬂﬁ!.hhﬂ 5 <meta http-equive”Content-Type"™ contentws"text/html: charsstwwindows-1252" />
Aj styles.css <title>Template l</title>
3 template 1.htm <link rels"agy] t" types"text " hrefs"styles.css™ />
] template2.htm w“; ”
The pop-up shows “includes/top.html.
This is the location of the page you will T rEm——
need to change to modify your logo. ludes/menu.hta® TAG="BODY" --><h2>
a specialized header bar.</p>
<div id="bodyl®>
<hl clase="gpecial”>Title (Heading 1.special)</hl>
<hl>Heading 1¢/hl>
<hi>Heading 2¢/h2>
<hi>Heading 3¢/h3> Lo s e e
<hé>Heading 4</hd> Include Page Properties.
<hS>Heading 5</h5>
Include pop-u
&l | BT pop-up
3
Tag Properties 0 x| 3
Tag Properties ' CSS Properties x|
Lol H

] <Coay>

<div id="head
<hl id=" ><a href="../index.htm">

i </body> This template comes with a blank graphic file. Open the blank graphic file in your
graphics editor, add your text/logo to the graphic and save. Most PixelMill
templates come with graphic source files that you can use to edit with your own
text. Alternatively, you can simply use your own logo graphic, but first make sure it
is sized appropriately and saved as a web-optimized image.

Add your new file to the images folder. Make sure that the image source is linking
to the new image file.

Modifying the menus/navigation

To modify the navigation links in this template, locate the includes folder and open the appropriate
menu (top, sub or bottom). Expression does not use FrontPage navigation.

For more information about using Include files in lieu of FrontPage Navigation, please view Corrie’s
webinar on moving from FP Navigation to using Include Pages. PixelMill Webinar
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Under the Hood: A close look at PixelMill’s CSS table-less templates.

Navigation

i When you open your menu page you will see a basic bullet list. Just edit

Getting Started the link you want to change and/or add your new links.
Template 1
Template 2

The STYLES.CSS page will take care of the formatting so that your

changed/new links have the same exact styles. Save your changes and

view your web page.

Navigation
. .y . . - Home
While editing your PixelMill template you B0 panalie
should use the File > Preview in browser to = Template 1
= Template 2
see a sample of your template. = My New Page Title (Head

After your changes have been made and you ________Heading 2 j Heading 1

are satisfied with the results, go ahead and -
pubhsh your website. NEW Iink added: ”My NeW Page”

Learn more...
While this overview should get you started working with our CSS templates, there are many new and
exciting things to learn about using CSS templates.

Corrie Haffly, Lead Designer at
PixelMill.com has already hosted

several webinars on using and Webinars and Seminars
tweaking CSS templates. | highly ® _ Online class envirc[)
g wi

ment :
recommend taking the time to view reefevant topics.

these webinars for a better
understanding of CSS templates.

Our Free CSS Webinars:
e Tweaking CSS Templates
e Managing CSS in Expression Web
e Replacing FP Link Bars in Expression Web.

The Free webinars can be viewed at http://pixelmill.com/products/education/seminars-webinars.aspx.

Our Premium Webinars:
e Tweaking CSS Templates Part 2
e Using CSS to Format Navigation Links

The Premium Webinars can be purchased at http://pixelmill.com/products/education/seminars-
webinars.aspx.
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